Adding a Target


#1

Hi all,

I am just starting with Open Hybrid. I am trying to perform the the basic Yun example of the slider and LED. I configured the Arduino YUN and connected it to the WiFi. The next step is adding the target. But when I access the board using objectName.local, the configuration page turns up. When I try to access objectName.local:8080, nothings shows up. I am following the steps given on the website but not getting the Hybrid Object - Administration page as shown on the website.

Also, I am not able to perform ‘npm install’ successfully on my MacBook. Could someone help me with that as well? I am getting this error ‘node-pre-gyp install --fallback-to-build’.

Thanks in advance.


#2

Hi @ahdeshpande welcome to the forum!

Have you followed these steps to prepare your Arduino Yun?


or

You do not need to install anything on your MacBook in case you want to run open hybrid only on an Arduino Yun.


#3

Yes, I have followed those steps and the Arduino Yun is configured in my Wi-Fi network. The next step is to add a target. So I am following this http://www.openhybrid.org/adding-object-and-marker.html. But this page doesn’t show up. I am directed to the configure board page.

I am following this example. http://www.openhybrid.org/arduino-yun-example.html
This requires me to add a target.

Appreciate your reply. Looking forward to have a working example soon.
Thanks again.

Regards,
Abhiraj.


#4

@ahdeshpande
You have to go to your_arduino_name.local:8080 for adding targets,
If you haven’t changed your arduinos’s name in the configuration page then. It will be arduino.local:8080


#5

Yes. I try to access it using myboardname.local:8080, but it shows the following:

This webpage is not available

ERR_CONNECTION_REFUSED

Is there any intermediate step that I am missing? The GITHUB link to the Yun image from this page http://www.openhybrid.org/arduino-yun-via-osx---linux.html isn’t working. But I got the image from https://github.com/openhybrid/Arduino-Yun-image.

Please let me know if you need any more information. I am just following the steps given on website and getting stuck.

Thank you again!

Regards,
Abhiraj.


#6

@ahdeshpande
I updated the link on the webpage.

It takes around 2 minute to fully load the system on the Arduino Yun.

There is a little white LED on the Arduino Yun that starts to light up after around 2 minutes indicating that the WLAN is working.

After some more seconds it should start blinking every second.
This indicates that the open hybrid platform is working.

Do you see the white LED blinking when you power up your Arduino Yun?


#7

The USB and ON LEDs are on. Both these LEDs are stable and don’t blink.
No other LEDs glow or blink.

Regards,
Abhiraj.


#8

Try to use the ip address of the yun instead of the name. Sometimes routers don’t resolve the name properly. For example: 192.168.0.2:8080/.


#9

@ahdeshpande try using the method @Carsten mentioned , you can find the ip of yun from your routers config page,
using the ip has worked for me when i had trouble with name :smile:


#10

@ahdeshpande If the white LED is never start blinking, then the open hybrid server is never started.

I assume that your system is never loaded from the SD card.
Because all Arduino Yun run from the same image and therefore run the same copy of the operation system, there is no other reason why your Arduino is not loading the platform.

Is the following message showing up when you reach step 13 from the installation guide?

Are you able to successfully reset the Arduino Yun with the Button?


#11

Thank @valentin, @V_Mohammed_Ibrahim and @Carsten for helping me out. It was the image I guess. I started from scratch and it worked. The LED is blinking and I can access the Hybrid Object Administration page. Thank you once again.

I’ll continue my exploration and ask queries if any. Appreciate your help.

Regards,
Abhiraj.