Arduino Yun.... Nothing responding to :8080


#1

I upgraded (i think) my Arduino Yun… with the latest image (downloaded .zip, followed instruction to get *sysupgrade.bin visible to luci web… and did reset to load from image. This all appeared to work.

Your “did it work?” verification seems to consist of “Once the Arduino has reset, your Arduino is a Hybrid Object.”

Now… I have nothing responding to :8080…

I see posts to the effect of maybe your router is blocking… here are the ports… Went thru all of that troubleshooting and finally ended with a proof by adjusting the /etc/uhttpd.conf file adding the line “list listen_http 0.0.0.0:8080”… and viola there are the web backend pages normally seen on port 80! So, no my port 8080 requests are not being blocked.

Ok, so it appears that nothing is starting the server which listens to port 8080.

So i’ve a number of questions but let’s start with 2: (1) There is a HybridObjects folder on the image created with the dd command (fromt he .zip file). Is this copied to the Arduino Yun filesystem? or is this MicroSD card supposed to remain in the slot and (2) what starts up the server? i don’t see anything in /etc/rc.d nor in the uhttp server startup that maps anything or causes anything to run. i also don’t see anything obvious in output from ps command. (list of processes running that would be responding to 8080.)

I followed all the instructions i can find, read all of the related Forum posts i can find, but without anything responding to :8080 i’m stalled.

Help!???

Regards,
Stephen


#2

(1) The MicroSD card is supposed to remain in the slot. The HybridObjects folder contains all the program and data files necessary and is not copied to the Arduino Yun filesystem

(2) Look in /etc/init.d/. I’m not sure what the actual startup script is called (probably object or HybridObject or something similar) and I don’t have access to a Yun at the moment. As far as I can remember in this script forever is started, which tries to keep the nodejs application (the server.js file in the HybridObjects folder) running.

You can try to manually start the application. Navigate to the HybridObjects folder and run node server.js

@valentin correct me if I’m wrong


#3

Thanks so much for the quick reply. I too was expecting to see something in init.d (and rc.d content?)

So, nothing found in init.d and no node application. So, I’m rebuilding my SD card in the hopes to rule out a failure with that step. It appears that the upgrade from the .bin file just didn’t happen. I did try both the orange button and the more advanced upload and install the .bin via the advanced pages. Neither caused the node application to be present or the init.d to contain anything new… are there any other forms of logs or something that i use to identify cause of lack of update?

-Stephen


#4

Hi @IronSheep
Step by setp:

  1. You have cloned the dmg image to the SD-Card and updated the YUN with the image on the SD-Card.
    Do not use the more advanced luci GUI. Instead use the Arduino GUI as described in the tutorial.

  2. After you updated the YUN can you still reach the Arduino GUI? It responds on the regular www port :80

  3. If Yes, when the Arduino starts, after approximately 2 minutes a white LED starts to glow for 5-10 seconds.
    This means that the WIFI starts. Then this LED should blink every second shortly. This blinking indicates that the Hybrid Object Server is loaded. From that moment on you should be able to reach the GUI at :8080.

Never remove the micro SD-Card, because this will cause the system to fall back to the OS that is saved on the YUN internal memory.

Lets see how it works out from here.

@Carsten This is all correct


#5

Hi @IronSheep the init.d file is called “nodeapp” and it is using “forever” to keep the server alive.


#6

Hi @valentin, thanks for the info. So, i have it all working now. The issues:

The instructions for building sd image on OS X didn’t work. I tried 3 - 4 times with no luck. I eventually formatted a card and dragged the content from the .dmg across and that’s where i was when i first reported that the install just wasn’t working. This was probably some sort of lack of contiguous allocation of .bin file content or something.

So, after trying OS X instructions one more time and ending up yet again with an empty SD card i simply went to a Windows machine and followed your instructions for the imaging the SD card on Windows. That finally worked and i am able to verify the /etc/init.d/nodeapp, the rc.d/… content and finally i have a node binary present! What a saga… but your example for Arduino Yun is working as you suggest. I now have questions about this which i’ll ask in a different thread.

Thanks all of you for your help!

-Stephen, KZ0Q


#7

Which part of the OS X instruction does not work?
sudo dd if=hybrid.dmg of=[your SDCard Name] takes a good amount of time to proceed.
Was that the problem?


#8

@valentin (answered in direct message)

Keep up the great work on this project!

-Stephen


#9

Thanks for the direct message.
I think about it like this: Every time something unclear becomes better, we win 100 people successfully getting it work.
Its the most relevant feedback to have. :smile: