First step to install Open Hybrid on raspberry pi?


#21

It couldn’t install on Debian 7.8 so I updated to Jessie.

Now there is a new problem installing the object dependencies. I’m getting, “fragmentation fault”

I’m about to give up on this on the pi


#22

Hi @professorminh,

this PI guide is like 3 days old.
Everyone is new to the community. Just give it a view days time until @KevinOrtman and @V_Mohammed_Ibrahim have figured out a fail save tutorial.

I will add a note to the webpage to lower the expectations a bit. :slight_smile:


#23

Hi @professorminh , are there any other details you can can provide?

Which version of the Pi are you using?
Are you using the Raspian Jessie image installed via NOOBS? (https://www.raspberrypi.org/downloads/)
At which step did you run into this error?
What exactly is the error message?

Nodejs on the Pi is fairly common, so I’m certain we can work through any issues you are running into, as long as the hardware is supported.


#24

@professorminh i would suggest you install a fresh Raspbein on the pi if you dont have any specific need with the debian OS


#25

I upgraded to JESSIE via NOOBS.
I’m getting ‘fragmentation fault’ at ‘npm install’

oh well. It wasn’t meant to be. I’ll install this on my laptop.


#26

@professorminh the server will run on the laptop just the same as the pi , until the GPIO interface for the pi is ready , it is the same weather you run it on pi or laptop , would you like to help us build the pi interface for GPIO? :smile:


#27

I’m more of an Arduino guy :slight_smile: although I’m pretty good with JS.
I’ve created something similar to open hybrid on the Arduino platform but the interface is web based and the ‘objects’ are all in memory so no coding for the users. The objects are generic device objects where the user can instantiate and adjust its parameters. There are pros and cons to this.


#28

Maybe there can be a “hardware interface” that talks back and forth with your own platform? :sunny:


#29

Yes, you can link hardware together. The arduino is the server and is the middle man to interpret signals from the linked hardware. It’s usually true/false flags to whatever parameter like the temperature is higher than 80F, flags a true. The lights look that the temperature sensor for a true signal to turn off. All devices are connected to the Arduino server. It’s all through an html form setting and the values are saved to the ‘Object’. I’m not familiar with Open Hybrid but I assume it works similarly.


#30

@valentin

we should put this info on the pi install test page ,these are the specification of the pi while testing the install manual

Pi model : B+ v 1.2
OS : Raspbian Wheezy
node : v 0.12.6


#31

Its uploaded to the page


#32

Mine is similar.

Pi 2 Model B v1.1
OS: Raspbian GNU/Linux 8.0 (jessie)
node: v0.12.9

Also, @V_Mohammed_Ibrahim / @valentin can we update the page with the install steps we put on https://github.com/openhybrid/object ? I ran into issues with the previously provided install steps, but the version on github was tested multiple times with a clean os install without fail.


#33

yes we should do that


#34

I added the new tutorial to the webpage and put both of you in the credits @KevinOrtman @V_Mohammed_Ibrahim


#35

@KevinOrtman is this setup more up to date and matching with the present guide on the webpage?

Pi 2 Model B v1.1
OS: Raspbian GNU/Linux 8.0 (jessie)
node: v0.12.9


#36

Yes, @valentin and the install should work for both.

@V_Mohammed_Ibrahim would you be able to run though the steps with your Pi? That would allow us to claim support for both Pi 1 B+ v1.2 and Pi 2 B v1.1 (though I don’t think the steps would cause any issues on the older hardware, it’s good to check).

I’m on Adafruit’s watchlist for a ZERO, once I get my hands on that, I’ll test similar.


#37

I’m running pi B and won’t install. So it looks like it’ll work for the newer pi.


#38

Okay , i will do a clean install of the OS and let you know :smile:


#39

@KevinOrtman i followed the steps , everything was fine until " npm install" it returns illegal instruction
dont know weather this is because i installed the OS by writing it to sd card using the win32diskimager , will try using NOOBS and test again


#40

I’m trying to get it running with raspbian jessie on a PI B+ v1.2. So far no luck, everything installs just fine, but when I try to run node or npm I run into a segmentation fault. I will continue to look into it and let you know if I succeed.