No object shows on Editor


#1

Strictly follow every step of the slider sample, but when I point my ipad to the printed image, there is no object shows up, only the image file itself, my arduino, ipad are in the same network and in the settings of the Editor I can see the Found Objects. But I can not operate on the ipad as the demo video shows, what’s wrong?


#2

Hi @sqiu welcome to the forum

1.did you upload all the files in the slider example folder to the server ?
2.Is the slider being displayed when pointed at the target image?
3.did you upload the arduino sketch to your arduino yun?

also refer this thread My Object does not show up in the Editor or anywhere else :smile:


#3

Hi V_Mohammed_Ibrahim, I solved the problem, now it works perfectly, two points:

  1. The image file uploaded should be the same as the target created in the Vufoira Target Manager, I was confused because the image in sample project is 600*600 while the guide shows to enter 300 for width.
  2. Mis-Understanding the developer mode, it is used for scale the interfaces.
    Thank you very much and I have all the staff set and worked.

#4

Hi, @sqiu,

I had the same problem here and I kind of solved this problem.

The slider image is shown on my iPhone but it is smaller than I expected.

I set the width as 600 in Vuforia. I guess I should set it to 300.


#5

The jpg target size you upload has no relation to the vuforia size.

But make the jpg image 600x600 px.
This is just a general good size, so that the download for the Reality Editor does not take to long.

You should use 300 for the vuforia size, as the system has been designed around this number.

You should scale your interface as shown in this video:


#6

I think I will rename the “developer” mode button in the Reality Editor to something more explaining like “move and scale”
What do you guys think?


#7

Yes.

I think that would be better and I found the switch cannot be disabled once it is enabled.

Device: iPhone 5S
Reality Editor: 1.5.7


#8

What do you mean by that? How can it not be disabled?


#9

Once I turn on this button on, I cannot turn it off. I usually delete the app and install the app again.

Also, I cannot switch Extended Tracking button. Do I need to do something before I can turn on this button?


#10

What iOS version do you have?

Can you try to load the Reality Editor in Airplane mode?
Can you enable and disable the buttons when you are in Airplane mode?


#11

Hey! It works.
I can switch both buttons on/off in Airplane mode and they can be controlled when I turn off the airplane mode.

How come it work like this?

iOS version: 9.2 (13C75)


#12

I have the feeling there is something wrong with your Arduino Yun and it is sending wrong data to the Reality Editor. The consequence is that the Reality Editor generates an error and stops the entire Javascript GUI.
When you are in airplane mode, the data will not be received and there is no error.

This would be an interesting case for debugging.
So with the following steps, when you reach the delete step, you can also make a backup first and send me the object.json files that you can find in each object folder.

Can you try the following:

  1. Put the Arduino SD-Card in your computer and go to the folder:
    SD-Card/HybridObjects/objects/

  2. Delete all objects in that folder (this is where your HTML interface is stored).

  3. Now reload the Developer Webpage and Add a new slider object.

  4. Upload the example.

  5. Programm the Arduino.

  6. Push the 32U4 Reset button on the Arduino yun.

  7. And restart your Reality Editor.

  8. You should now be able to see it.


#13

@valentin i also came across the developer button problem , but was able to switch off after some tries, it must be some problem with the app, it was like the buttons were not responding to the touch


#14

I know, these buttons are a bit hard to operate and sometimes you need a couple of tries.
I will try to implement better responsive buttons down the road.

But the problem that @ivanlin has nothing to do with the operability of the buttons.

@ivanlin please share the object.json files that are in the object folders of your Yun SD-Card. We will then be able to see what is going on in your objects.


#15

Hi, @valentin,

I created ‘target’ in Vuforia.
I object.son here for reference.

/mnt/sda1/HybridObjects/objects/target/object.json

{“objectId”:“targetl139he03smhk”,“ip”:“10.8.7.59”,“version”:“0.3.1.1”,“rotation”:0,“x”:12.033831725140772,“y”:-74.22854793432225,“scale”:1,“visible”:false,“visibleText”:false,“visibleEditing”:false,“developer”:true,“matrix3dMemory”:[0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0],“objectLinks”:{},“objectValues”:{},“folder”:“target”}


#16

I am confused about the
“x”: 12.033831725140772,
“y”: -74.22854793432225,
values. Y is very low. Can you see your virtual slider interfaces? It might be totally out of sight.

Also there are no IO-Points defined at this point.
You can see this with the “objectValues”:{} Array.
It is empty.

Please follow the steps I explained earlier and report back if it worked.

If nothing works, please follow the examples from the Webpage once more and try not to make any changes to the examples until you see your interface.

You can also change the X and Y values in the object.json file to “0”. Then upload it via the webinterface. This will reset the position of the user interface to its origin, once you restart the Arduino Yun and the Reality Editor.