readWrite example disturbs boot of linux chip


#1

Hello,

when I tried the readWrite example on an Arduino Yun I noticed that when I uploaded the sketch and rebooted the Yun, the linux chip wouldn’t boot. It seems to be a problem with the serial communication between the ATmega and linux chip. When I added a timeout in the beginning of the setup() part of the sketch, it worked fine. Maybe in HybridObject.cpp in HybridObject::init() the while construct blocks it? I’m not sure… I’m using the Arduino IDE 1.6.6. Did anyone else run into this problem?

Greets
Carsten


Arduino Yun wont boot wifi after Unplug
#2

I also came up on such a problem , one of the reasons i found was that there was a difference in boot time for the Linux and arduino processors and that is why the serial communication problem occurs , the delay at the Beginning may have delayed the serial comm request till the Linux processor boots up .and hence solves the problem


#3

Hi both of you,
This happens if your Arduino Yun has an old firmware.
Before Release 1.3 (July 14th, 2014) the Yun would trigger the fail-save boot mode if there is any activity on the serial interface during the boot process. With Release 1.3 it has been changed to trigger the fail-save boot mode with typing “ard” on the serial interface. A timeout at start was not necessary anymore and therefore we removed it. It looks like that you must have a board that is older then release 1.3.

If you want to update your yun firmware, you need to do the following instructions to update your arduino yun: https://www.arduino.cc/en/Tutorial/YunUBootReflash

It is a bit more complicated…
If it is to complicated then you can just add the delay in the setup, the way you have described it.