New Reality Editor Version 1.5.7


#65

@Sunny @valentin he problem might be because the option to enable devices to discover each other on network might not be working/ enabled on windows
Once it happened to me. I don’t remember exactly how i fixed it , but it is probably the case here


#66

http://windows.microsoft.com/en-us/windows/what-is-network-discovery#1TC=windows-7


#67

@valentin @V_Mohammed_Ibrahim I am very happy that I can see a bird in iphone web browser.But when I open the reality editor,the bird dosen’t appear.


#68

Is the reality editor showing the object in list ?


#69

@V_Mohammed_Ibrahim @valentin No,nothing in the “Found Objects in this Network”.


#70

@Sunny I can only see one last reason:
Your iPhone does not receive the broadcasting messages from the Computer. This has to be the reason why nothing is showing up in your editor.

This can have two reasons:

  1. Your computer firewall is blocking outgoing UDP broadcasts.
  2. Your Router is blocking the broadcasting signals.

On windows machines most ports are blocked by anti virus tools, traffic control software or firewalls.

For a test, please stop all firewalls, anti virus tools and traffic control software on your computer.
Make sure that TCP/IP port 8080 is reachable and allows for sending (which you just did).
Make sure that UDP port 52316 is reachable and allowed to send data.

If the reality editor is still not showing any objects continue with the following:

I have written another test.
Please download https://github.com/openhybrid/object/tree/v1.6.0_withoutExtraHardwareInterfaces again.
Perform the installation with npm install again and then run the following test:
node udpBroadcastTest.js

You should see messages popping up in your computer similar to:
Message received: test with ID: xxxxxxxx

If this is the case, install the same v1.6.0 on a second computer and run node udpBroadcastTest.js on both computer in the same time.

You should see messages with different ID’s popping up in both computers.
Message received: test with ID: xxxxxxxx
Message received: test with ID: yyyyyyyy

If you do not see messages from two different computer popping up while both computer are running the test, your network or computer is still blocking UDP broadcasting messages.


#71

@valentin I use 3 windows PC(A B C) to do this test.All PC are stop firewall.A is use as a router.B and C are installed the same v1.6.0. When I run “node udpBroadcastTest.js”
B only popping up: Message received: test with ID: xxxxxxxx
C only popping up: Message received: test with ID: yyyyyyyy
I do not see
Message received: test with ID: xxxxxxxx
Message received: test with ID: yyyyyyyy
In both PC.
So,that is to say, Share a Wifi hotspot open by PC with others is usesless to this programe?


#72

@Sunny Now we know that the broadcasting messages are not received by the other side.
This is the reason that the Reality Editor can not see the objects.

This can have two reasons. Your WIFI Sharing computer is blocking client to client communication or it is blocking udp broadcasting. For the second reason I could find: http://stackoverflow.com/questions/21757185/windows-7-block-udp-broadcast-message

Never the less. I think it is getting to complicated here.
I highly advise to use a router instead of an internet sharing. You can find a small router for $10-14. I could find the same model in every international store including china.


#73

Thanks a lot !@valentin.I use a TP-LINK TL-WR885 router to do this test,but the same phenomen occurs.
PC B only popping up: Message received: test with ID: xxxxxxxx
PC C only popping up: Message received: test with ID: yyyyyyyy
So I use a software “Network Assistant”,I discover B and C’s UDP 8080 and 52316 ports can communicate with each other.
But when I start the server and use this software to send message to UDP 52316 port from UDP 8080,it will occur these phenomen:
1.Send letter:



node get message but the server down.
2.Send number,nothing happen.
So I think unicast is ok,but broadcast I am not sure, can TP-LINK default mode block broadcast?


#74

@Sunny
If you send messages to 127.0.0.1 you are sending messages basically to your localhost.
This does not prove that any UDP messages leave your computer.

If you use a router like the TP-Link everything should work out of the box.
Some router prevent client to client communication when you are for example in a guest network mode.
Please check if your TP-Link has such a client to client setting.

Please follow the examples above for how to prevent your windows from blocking UDP broadcasts.
Again. Checking connections for 127.0.0.1 do not really give you any proof as it is just A computer internal address.


#75

Hi valentin,I got it!Because of changing a router.When I open the app something appear in the"Found Objects in this Network",but i still can’t find the bird.


And something veryyyyy funny I want to share:
I use 2 PC to do udp broad cast test, one can get the other’s id,the other one can’t get.

And it is proved that the computer who can get the other’s id can’t spread message.that is it can receive message,but it can’t send message.:confused::pensive::unamused:


#76

@Sunny if the object is detected then the bird should be displayed too , did you try moving the ipad closer/away from the marker image ? or try changing the orientation of the ipad (rotating it )?


#77

I just try this example of readWrite without setting Vuforia, just upload target.jpg and target.zip.Dose it work?


#78

@Sunny I see. I think there is a mistake in the example.
You should call your object “slider” because that target.jpg and target.zip was generated for an object called slider.
When your object is called test, it will not work.


#79

So I should named the object slider,and change the name of .zip and .jpg to sliderXXXXXXXXX?


#80

It has nothing to do with what is the name of your target jpg or zip file. Renaming does not work.
The data is within the zip file.

Two choices:

  1. You follow the guide on how to generate a target for your object.
  2. You use a pre-generated target, but then you have to give your object the name for which the target was generated.

If you use the readWrite example provided with the Arduino library then you have to call the object slider.
If you use any of the other pre-generated targets use the name of their files. For example obj45.jpg and obj45.zip works with an object that is called obj45. These files have been named according to the object they were initially generated for.


#81

Oh,I reabuilt an object named slider,but when I upload the target.jpg and the target.zip in reaWrite example,should i change their name to silderOr8vjiw6frfn?


I do this just now,but it seems doesn’t work.:fearful:


#82

Please follow the guide…
it does not matter what name you give to your files. This is not relevant.
However, in the vuforia manager you have to give it the name generated in point 4 of the guide.
That is all. It will generate a zip file with a marker responding to your object name.


#83

valentin~I try the sensorAndSlider,I got it!


But I don’t know why I use the example of readWrite I cannot see the bird.


#84

This is because the readWrite example has a UI interface that is a slider.